Some FlexBooks are not loading correctly
Incident Report for CK-12 Foundation
Resolved
This incident has been resolved.
Posted Sep 14, 2022 - 23:01 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 14, 2022 - 10:11 PDT
Investigating
We are currently investigating this issue.
Posted Sep 14, 2022 - 09:05 PDT